Stability issues in several regions

Incident Report for EngageOne™ Communicate

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 15:34 UTC

Monitoring

Monitoring — Endpoint error rate returning to normal following AWS service recovery. Actively monitoring CloudWatch metrics, error rates, and application logs to confirm full stabilization. No further action required at this time.
Posted Jun 26, 2026 - 15:06 UTC

Identified

Identified — AWS infrastructure degradation identified as root cause. No application-level errors found in logs;
Posted Jun 26, 2026 - 15:05 UTC

Update

We are continuing to investigate this issue.
Posted Jun 26, 2026 - 15:03 UTC

Investigating

We currently investigating this issue.
Posted Jun 26, 2026 - 14:37 UTC
This incident affected: Web Platform Production (Core, Email, Email (Advanced), Documents, Chat, Video).